Posted by: Mrkim [x] - (71.164.244.---)
Date: September 29, 2011 05:48AM
I haven't been able to reconcile VM ware in my mind yet, kinda like with women, so ... My best understanding always comes from mentally being able to grok a thing though this has been elusive with VM ware.

If it's caching everything into RAM isn't that also depleting the RAM as a resource in a real time sense or is that inconsequential in the grand scheme of things?

Any idea what would lead to a near monopolization of only 2 cores for all functions while not evenly distributing the overall load instead across all 8? Watchin this stuff in real time freaked me out as it lead me to feel those 2 cores would eventually fail, making the CPU a dead duck.

One of the luxuries of all my puters bein toys, 'cept for the server, is when I break 'em it's more bother than panic in gettin 'em up again.

BTW, while talkin about HD issues (what a segway eh:>winking smiley, in my Fedora server it still recognizes all the HDs but shows 2 as empty, and unable to store more data on. The reality is I can remove the HD, drop it in the ESATA cradle and read it fine on another machine, while even doin this same operation with the server machine itself, it still can't read the drive. As a side note, the HD is completely filled and can not take any more data.

W all 5 2TB drives full I snagged another one, dropped it into the server and lost the functionality of 2-2TB HDs in the bargain, what a deal eh drinking smiley
Posted by: pulse [x] - (Moderator)
Date: September 29, 2011 07:04AM
The last one sounds like some kind of weird controller issue.

I bit the bullet last week and bought 4 x 3TB drives for the new fileserver I'm building (this is on top of the 2 NAS' I have each with 5 x 2TB and my desktop with another ~4-5Tcool smiley.

Building quite the porn empire.

The operating system is smart enough with cached data to mark it as such, so it's immediately tossed the instant something else needs memory. It might cost you 1/10000th of a second for it to do that, vs the maybe 1/100th of a second it saves you a thousand times a day by having the cached data there. It's a win, there really is no downside. As I said, unused ram is just wasted. You may as well put it to work, even if it's low yield work like long term data caching.

As for the CPU threads.. meh. It's really not likely to burn out a core, and if the CPU is fucked it's fucked. Also note you're looking at threads if you have 8 of them, not cores.. Since your CPU core is capable of 2 threads (2 virtual CPUs) you were likely only using HALF of 2 cores rather than all of any.

And VMWare is ace. So is Sun/Oracle's VirtualBox for a virtualisation client (rather than something like ESX which is more hardcore). Would solve Woberto's issues too, running VirtualBox on Linux works just fine, could put your VMs there instead.
Posted by: Mrkim [x] - (71.164.244.---)
Date: September 29, 2011 12:41PM
Sheesh dude, that's a buttload O storage. How much of it's actually already filled?

Speakin of porn empires, a software engineer buddy of mine was in between gigs a few yrs back, and bored, so he wrote a spider program and used it to rip everything from a porn site as fast as his connection could stream it all back to his server.

He'd set up one of their 2-3 day $1.99 trial subscription deals then rip everything they had and end his subscription. He amassed quite a collection smiling bouncing smiley

These days he's out in Cali. rakin in the big bucks workin on a 3D for Blu-Ray project.

This is the same cat that turned me on to Linux initially and I really miss havin him around, he was a hoot.

When he 1st went to work for his company it was for an interesting audio/video over the net in real time project that I'm amazed the news agencies never bought in to. At the time (5+yrs) ago the computer needed to handle it all was like $20k in hardware but it sure seemed like a winner for news agencies to be able to eliminate the lag time they have in across the globe interviews where that lag leads to lotsa pregnant pauses in the interviews spinning smiley sticking its tongue out

What would be the simplest way to set up the capability for each machine in my network to share each others HDs? I've looked at several ways to do so and wonder what would be the best usin the KISS method as a parameter? For those like myself who are softwarily challenged the 2-S's at the end of that are really beneficial (headexplode)

On to a totally different topic all together. I came across an interesting TED talks show last night on how the Stuxnet virus was engineered and implemented to take down Irans uranium enrichment facility hardware. I found it fascinating as well as frightening.

The presenter finished up in saying the same basic building blocks of that viral approach were likely to become the next wave of cyber terror and could be used to similarly take down power generation plants, govt and private networks, financial networks and even the 'net itself on a national level. I could certainly see how this type of action could be hugely detrimental to overall security on a global scale eye popping smiley

Edited 2 time(s). Last edit at 29/09/2011 01:28PM by Mrkim.
Posted by: pulse [x] - (Moderator)
Date: October 03, 2011 11:21PM
Mrkim Wrote:
> What would be the simplest way to set up the
> capability for each machine in my network to share
> each others HDs? I've looked at several ways to
> do so and wonder what would be the best usin the
> KISS method as a parameter? For those like myself
> who are softwarily challenged the 2-S's at the end
> of that are really beneficial (headexplode)

About 11TB is actually full, rest is room for expansion and testing. I'm also now using ISCSI for virtual machine storage, so assigning each virtual a slice of disk for use over the network.

I'm not sure about each machine sharing EACH OTHER's disks. It really depends on the OS of them all and how it's laid out. Your best bet with a combo Linux/Windows environment would be to share those directories via SAMBA (Win) and CIFS (Linux) to each other, and map the network drive off each respective machine.

Or you can have one system which has all your media content and exports that to everything else. That's the way I do it. Everything streams music/video off my NAS, no matter what room it's in or what operating system/media player it runs.

Central is best IMO because it's less shit to keep track of.
Posted by: quasi [x] - (208.78.130.---)
Date: October 04, 2011 05:05PM
Kim, I've been pondering what you replied to me about my statement "if it ain't broke, don't fix it." I like you and respect you a lot, and this isn't meant personally, but the thirst for things that are bigger, better, and faster is a large part of the reason our economy is in the toilet now thanks to peoples' willingness to borrow money to have those things and the lenders' stupidity in lending them the money. I live within my means even if I have to settle for something a little less that does the job I ask of it. I have a couple of old cars, but they're paid for. I have a home and lot that I own outright. And I have a seven year old PC with Windows XP that does everything I need. Clint Eastwood said a man's got to know his limitations and I live within mine, often with a lot less aggravation than the folks who are still after bigger, better, faster.
Posted by: fossil_digger [x] - (76.185.188.---)
Date: October 04, 2011 05:53PM
i don't think he's doggin' ya, just laughin' witcha. grinning smiley

hell, my mom was went from being on AOL with a crap ass computer to a fios connection with a core 2 duo and Ubuntu last year and can't believe she was ever so lame. grinning smiley
Posted by: Mrkim [x] - (71.164.244.---)
Date: October 04, 2011 06:26PM
quasi, thanks for the vote of confidence. My point was a discussion on differences between the typical Windows/Mac user compared to a typical Linux person.

I agree the whole More, more, more thing has an impact, but that was not where I was goin at all.

I own everything but the land I live on and carry a 0$s credit line myself. If there's no $$ in the bank, I don't buy it and ... I live very cheaply, so smileys with beer
Posted by: quasi [x] - (208.78.130.---)
Date: October 04, 2011 07:31PM
It's cool, I know that's not where you were goin' but some folks get to thinkin' they have to follow despite the consequences. Keepin' up with the Joneses is a dangerous ambition from which I try to abstain.
Posted by: fossil_digger [x] - (76.185.188.---)
Date: October 04, 2011 08:20PM
i hate disclaimers. Dancing Green Banana!
Posted by: pro_junior [x] - (Moderator)
Date: October 05, 2011 07:06AM
I need more $$$ so I can get more stuff...
Posted by: woberto [x] - (144.136.97.---)
Date: October 05, 2011 08:51AM
Well my laptop turned out OK, it was actually the hard drive that crapped itself.
Good old www.pendrivelinux and I just re-installed to OS and the swap to the back part of the disk.
Dodgey I know but itś a workhorse, plus I have a cloned laptop as a backup. Now I use that one for work and the one with the crappy sector is the backup now.
I might need to re-invest in some hardware and then I will try Linux only VMware.
Posted by: fossil_digger [x] - (76.185.188.---)
Date: October 05, 2011 01:29PM
copy your home folder once a week in case of an O.S. reload the home folder...and bingo! golden. Dancing Green Banana!
Posted by: Mrkim [x] - (71.164.244.---)
Date: October 09, 2011 03:23AM
Aww yeah baby!

I've been wanting to set up Ubuntu server and try it out but the terminal only thing had me put off from doin so.

Last night duggin around I came across info on installin a GUI on the newer 11.04 64 bit version.

I DLed the server version .iso and installed it onto a spare 40gig HD sittin in my external HD cradle. Followed the instructions to install the GUI and badda-bing-badda-bang I had a server with a nice GUI that I was familiar with and actually understood, unlike the Fedorka I has been usin!

It integrates easily with my other ubuntu OS's and so far so good Dancing Green Banana!
Posted by: fossil_digger [x] - (76.185.188.---)
Date: October 09, 2011 01:46PM
i got a brand new in the box Winblows 2003 server Enterprise edition with a copy of Xp pro free off Craigslist yesterday and i can't find anyone interested in it. (*facepalm*)totally lostsmiling bouncing smileytotally lost(*facepalm*)

Edited 1 time(s). Last edit at 09/10/2011 01:49PM by fossil_digger.
Posted by: woberto [x] - (144.136.97.---)
Date: December 14, 2011 10:23AM
10 minutes of animation and it's not really about Linux...
...but you should still watch it.
Posted by: Mrkim [x] - (184.20.81.---)
Date: November 08, 2013 06:02AM
Well, I finally dumped off Ubuntu for a new OS, CentOS. haddn had it loaded up but for a few hours so far but it seems quite doable.

My Ubuntu 10.10 was outta updates and some stuff had stopped workin so I figured it was time to try somethin different.

The look and feel of it reminds me a lot of Fedora, which I've played with before so it's not all new.

At least it still runs on the Gnome desktop which is another reason why I decided to abandon Ubuntu since I absolutely despise the Unity set up ..... (throwup)

So far so good and I'll just hafta see how it strikes me a little further down the road once I get more seat time with it.
Posted by: pulse [x] - (Moderator)
Date: November 08, 2013 08:46AM
Slackware 14.1 came out today.

Or there's Solaris 11.1 x86...

Be a real man winking smiley
Posted by: Mrkim [x] - (184.62.16.---)
Date: November 16, 2013 03:54PM
Sheesh dude, I looked at both of those and there's enough Greek in just the description pages to scare hell outta me drinking smiley

But .... if ya really wanna be helpful you could lay your best command line fix for the file permissions issue I'm havin. Since I loaded centOS I now have 11TBs of unusable files since I'm locked outta all of 'em.

Already tried chown -R kim:kim /dev/name of drive and several other routes to get to the magical solution, yet nothin seems to phase the death grip on my files!!

Sure I can log in as root and make changes manually , but oddly enough even if I take more than one file/folder/directory at a time and attempt to change the permissions, even that's a no go, meaning it would have to be done file by file, and uhhhhh, I'd problee be done with that about the same time I turn 100 or so.

Even clicking properties > permissions on a folder, changing it, then telling it to change permissions on all files in the folder dudn work, which leaves me with a very big WTF (headexplode)

Any ideas??
Posted by: woberto [x] - (121.44.110.---)
Date: November 17, 2013 02:02AM
What about good old chmod 777 ?
Posted by: Mrkim [x] - (184.62.16.---)
Date: November 17, 2013 04:57AM
Yep, tried that as well, but no joy (headexplode)
Posted by: pulse [x] - (Moderator)
Date: November 17, 2013 06:26AM
cd /root/of/problem
find . -exec chmod 755 {} \;
Posted by: pulse [x] - (Moderator)
Date: November 17, 2013 06:27AM
You should also be able to do chown -R kim:kim /root/of/problem .. similar chmod -R 755 /blah/blah

The above post works well if there's lotsa files (eg makes the command line too long for the shell to handle)
Posted by: Mrkim [x] - (184.62.16.---)
Date: November 17, 2013 05:34PM
Thanks guys, but still no bueno (throwup)
Posted by: pro_junior [x] - (Moderator)
Date: November 17, 2013 10:42PM
Posted by: pro_junior [x] - (Moderator)
Date: November 17, 2013 11:51PM
see also, this
Posted by: Mrkim [x] - (184.62.16.---)
Date: November 18, 2013 01:59AM
Damn PJ, those were both great, thanx (matrix)

smoking smiley
Posted by: pro_junior [x] - (Moderator)
Date: November 18, 2013 03:56AM
glad I could help smileys with beer
Posted by: BlahX3 [x] - (68.186.2.---)
Date: November 18, 2013 05:55AM
You forgot to tell him about the three frog hearts and the blood of a virgin. Smear them on the monitor while chanting "Kazi, mwanaharamu wee!"
Posted by: woberto [x] - (121.44.110.---)
Date: November 18, 2013 06:48AM
Hmm. When you crate your users in Ubuntu the home directory permissions are set to group and others read. But not in CentOS.
What do you get when you interrogate your /home directory? I think centOS command might be
/home$ ||
And might look something like
total 12
drwx------ 2 drj

in which case try
$ sudo chmod g+rx,o+rx drj
Also, you could check how your sudo permissions got setup by default but if you want to fiddle around with your /etc/sudoers file remember to use visudo.
Posted by: Mrkim [x] - (184.62.16.---)
Date: November 18, 2013 11:50AM
Meh, after many hours fargin with CentOS I installed Ubuntu 12.04 and lo and behold, all the permissions issues went away. Dunno WTF CentOS's problems were related to but I'd just grown too frustrated dealin with it to care anymore. It made absolutely no sense how the permissions controls could have evaded command line manipulation with root empowerment.

The whole reason I'd decided to switch to CentOS was all further upgrades in Ubuntu required usin the dorky Unity desktop, which I absolutely despise. Whoever dreamed up that interface should be drug out by their heels, strung up and left for the buzzards.

I chose 12.04 because it was the last version to allow usin Gnome, though it's a pretty locked down interface compared to the older versions, but at least it's navigable in a much more straight forward manner than Unity.

A buddy of mine's just finishin up a new distro of a linux OS he's aptly named Patriot he says will seal up the currently open back door issues parameters within selinux allow. I've agreed to be the test guinea pig for it, since if anyone can break it, I can, with a quickness clown
Your Name: 
Your Email: